Print
Parent Category: Tutorials
Hits: 3107

There are already many requests to use php 5.3, so upgrading php to version 5.3 in Plesk become something

often required.

Here is an example of seting php version 5.3 on Plesk 10. It a real example:

 

[root@u15559315 httpdocs]# php -v
PHP 5.1.6 (cli) (built: Mar 31 2010 02:39:17)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
[root@u15559315 httpdocs]#
[root@u15559315 httpdocs]#
[root@u15559315 httpdocs]# cd
[root@u15559315 ~]# wget -q -O - http://www.atomicorp.com/installers/atomic | sh

Atomic Archive installer, version 2.0

BY INSTALLING THIS SOFTWARE AND BY USING ANY AND ALL SOFTWARE
PROVIDED BY ATOMICORP LIMITED YOU ACKNOWLEDGE AND AGREE:

THIS SOFTWARE AND ALL SOFTWARE PROVIDED IN THIS REPOSITORY IS
PROVIDED BY ATOMICORP LIMITED AS IS, IS UNSUPPORTED AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL ATOMICORP LIMITED, THE
COPYRIGHT OWNER OR ANY CONTRIBUTOR TO ANY AND ALL SOFTWARE PROVIDED
BY OR PUBLISHED IN THIS REPOSITORY BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.

Do you agree to these terms? (yes/no) [Default: yes]

Configuring the [atomic] yum archive for this system

Installing the Atomic GPG key: OK
Downloading atomic-release-1.0-13.el5.art.noarch.rpm: OK



The Atomic Rocket Turtle archive has now been installed and configured for your system
The following channels are available:
atomic          - [ACTIVATED] - contains the stable tree of ART packages
atomic-testing  - [DISABLED]  - contains the testing tree of ART packages
atomic-bleeding - [DISABLED]  - contains the development tree of ART packages


[root@u15559315 ~]# yum --enablerepo=atomic-testing upgrade php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* atomic: www5.atomicorp.com
* atomic-testing: www5.atomicorp.com
atomic                                                                                                                                                                        | 1.9 kB     00:00    
atomic/primary_db                                                                                                                                                             | 726 kB     00:00    
atomic-testing                                                                                                                                                                | 1.9 kB     00:00    
atomic-testing/primary_db                                                                                                                                                     |  94 kB     00:00    
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.6-5.el5.art set to be updated
--> Processing Dependency: php-cli = 5.3.6-5.el5.art for package: php
--> Processing Dependency: php-common = 5.3.6-5.el5.art for package: php
--> Running transaction check
---> Package php-cli.x86_64 0:5.3.6-5.el5.art set to be updated
--> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-xml
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-pdo
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-gd
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-mbstring
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-mysql
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-imap
---> Package php-common.x86_64 0:5.3.6-5.el5.art set to be updated
--> Running transaction check
---> Package libedit.x86_64 0:3.0-2.20090923cvs.el5.art set to be updated
---> Package php-gd.x86_64 0:5.3.6-5.el5.art set to be updated
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
---> Package php-imap.x86_64 0:5.3.6-5.el5.art set to be updated
---> Package php-mbstring.x86_64 0:5.3.6-5.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.3.6-5.el5.art set to be updated
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
---> Package php-pdo.x86_64 0:5.3.6-5.el5.art set to be updated
---> Package php-xml.x86_64 0:5.3.6-5.el5.art set to be updated
--> Running transaction check
---> Package mysqlclient16.x86_64 0:5.1.57-1.el5.art set to be updated
---> Package t1lib.x86_64 0:5.1.2-2.el5.art set to be updated
--> Processing Dependency: libXaw.so.7()(64bit) for package: t1lib
--> Processing Dependency: libXt.so.6()(64bit) for package: t1lib
--> Running transaction check
---> Package libXaw.x86_64 0:1.0.2-8.1 set to be updated
--> Processing Dependency: libXext.so.6()(64bit) for package: libXaw
--> Processing Dependency: libXmu.so.6()(64bit) for package: libXaw
---> Package libXt.x86_64 0:1.0.2-3.2.el5 set to be updated
--> Processing Dependency: libICE.so.6()(64bit) for package: libXt
--> Processing Dependency: libSM.so.6()(64bit) for package: libXt
--> Running transaction check
---> Package libICE.x86_64 0:1.0.1-2.1 set to be updated
---> Package libSM.x86_64 0:1.0.1-3.1 set to be updated
---> Package libXext.x86_64 0:1.0.1-2.1 set to be updated
---> Package libXmu.x86_64 0:1.0.2-5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================================
Package                                         Arch                                     Version                                                     Repository                                Size
=====================================================================================================================================================================================================
Updating:
php                                             x86_64                                   5.3.6-5.el5.art                                             atomic                                   1.4 M
Installing for dependencies:
libICE                                          x86_64                                   1.0.1-2.1                                                   base                                      54 k
libSM                                           x86_64                                   1.0.1-3.1                                                   base                                      28 k
libXaw                                          x86_64                                   1.0.2-8.1                                                   base                                     329 k
libXext                                         x86_64                                   1.0.1-2.1                                                   base                                      37 k
libXmu                                          x86_64                                   1.0.2-5                                                     base                                      63 k
libXt                                           x86_64                                   1.0.2-3.2.el5                                               base                                     181 k
libedit                                         x86_64                                   3.0-2.20090923cvs.el5.art                                   atomic                                    81 k
mysqlclient16                                   x86_64                                   5.1.57-1.el5.art                                            atomic                                   1.8 M
t1lib                                           x86_64                                   5.1.2-2.el5.art                                             atomic                                   208 k
Updating for dependencies:
php-cli                                         x86_64                                   5.3.6-5.el5.art                                             atomic                                   2.6 M
php-common                                      x86_64                                   5.3.6-5.el5.art                                             atomic                                   973 k
php-gd                                          x86_64                                   5.3.6-5.el5.art                                             atomic                                   208 k
php-imap                                        x86_64                                   5.3.6-5.el5.art                                             atomic                                    87 k
php-mbstring                                    x86_64                                   5.3.6-5.el5.art                                             atomic                                   2.3 M
php-mysql                                       x86_64                                   5.3.6-5.el5.art                                             atomic                                   159 k
php-pdo                                         x86_64                                   5.3.6-5.el5.art                                             atomic                                   117 k
php-xml                                         x86_64                                   5.3.6-5.el5.art                                             atomic                                   222 k

Transaction Summary
=====================================================================================================================================================================================================
Install       9 Package(s)
Upgrade       9 Package(s)

Total download size: 11 M
Is this ok [y/N]: y
Downloading Packages:
(1/18): libSM-1.0.1-3.1.x86_64.rpm                                                                                                                                            |  28 kB     00:00    
(2/18): libXext-1.0.1-2.1.x86_64.rpm                                                                                                                                          |  37 kB     00:00    
(3/18): libICE-1.0.1-2.1.x86_64.rpm                                                                                                                                           |  54 kB     00:00    
(4/18): libXmu-1.0.2-5.x86_64.rpm                                                                                                                                             |  63 kB     00:00    
(5/18): libedit-3.0-2.20090923cvs.el5.art.x86_64.rpm                                                                                                                          |  81 kB     00:00    
(6/18): php-imap-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                   |  87 kB     00:00    
(7/18): php-pdo-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                    | 117 kB     00:00    
(8/18): php-mysql-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                  | 159 kB     00:00    
(9/18): libXt-1.0.2-3.2.el5.x86_64.rpm                                                                                                                                        | 181 kB     00:00    
(10/18): php-gd-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                    | 208 kB     00:00    
(11/18): t1lib-5.1.2-2.el5.art.x86_64.rpm                                                                                                                                     | 208 kB     00:00    
(12/18): php-xml-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                   | 222 kB     00:00    
(13/18): libXaw-1.0.2-8.1.x86_64.rpm                                                                                                                                          | 329 kB     00:00    
(14/18): php-common-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                | 973 kB     00:00    
(15/18): php-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                       | 1.4 MB     00:00    
(16/18): mysqlclient16-5.1.57-1.el5.art.x86_64.rpm                                                                                                                            | 1.8 MB     00:00    
(17/18): php-mbstring-5.3.6-5.el5.art.x86_64.rpm                                                                                                                              | 2.3 MB     00:00    
(18/18): php-cli-5.3.6-5.el5.art.x86_64.rpm                                                                                                                                   | 2.6 MB     00:00    
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                5.8 MB/s |  11 MB     00:01    
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating       : php-common                                                                                                                                                                   1/27
warning: /etc/php.ini created as /etc/php.ini.rpmnew
Updating       : php-pdo                                                                                                                                                                      2/27
Installing     : libICE                                                                                                                                                                       3/27
Installing     : libXext                                                                                                                                                                      4/27
Installing     : libSM                                                                                                                                                                        5/27
Installing     : libXt                                                                                                                                                                        6/27
Installing     : libXmu                                                                                                                                                                       7/27
Installing     : libXaw                                                                                                                                                                       8/27
Installing     : t1lib                                                                                                                                                                        9/27
Installing     : mysqlclient16                                                                                                                                                               10/27
Installing     : libedit                                                                                                                                                                     11/27
Updating       : php-cli                                                                                                                                                                     12/27
Updating       : php                                                                                                                                                                         13/27
Updating       : php-xml                                                                                                                                                                     14/27
Updating       : php-imap                                                                                                                                                                    15/27
Updating       : php-mbstring                                                                                                                                                                16/27
Updating       : php-mysql                                                                                                                                                                   17/27
Updating       : php-gd                                                                                                                                                                      18/27
Cleanup        : php                                                                                                                                                                         19/27
Cleanup        : php-common                                                                                                                                                                  20/27
Cleanup        : php-cli                                                                                                                                                                     21/27
Cleanup        : php-xml                                                                                                                                                                     22/27
Cleanup        : php-imap                                                                                                                                                                    23/27
Cleanup        : php-mbstring                                                                                                                                                                24/27
Cleanup        : php-mysql                                                                                                                                                                   25/27
Cleanup        : php-gd                                                                                                                                                                      26/27
Cleanup        : php-pdo                                                                                                                                                                     27/27

Dependency Installed:
libICE.x86_64 0:1.0.1-2.1                  libSM.x86_64 0:1.0.1-3.1                libXaw.x86_64 0:1.0.2-8.1      libXext.x86_64 0:1.0.1-2.1 libXmu.x86_64 0:1.0.2-5 libXt.x86_64 0:1.0.2-3.2.el5
libedit.x86_64 0:3.0-2.20090923cvs.el5.art mysqlclient16.x86_64 0:5.1.57-1.el5.art t1lib.x86_64 0:5.1.2-2.el5.art

Updated:
php.x86_64 0:5.3.6-5.el5.art                                                                                                                                                                      

Dependency Updated:
php-cli.x86_64 0:5.3.6-5.el5.art       php-common.x86_64 0:5.3.6-5.el5.art     php-gd.x86_64 0:5.3.6-5.el5.art      php-imap.x86_64 0:5.3.6-5.el5.art     php-mbstring.x86_64 0:5.3.6-5.el5.art   
php-mysql.x86_64 0:5.3.6-5.el5.art     php-pdo.x86_64 0:5.3.6-5.el5.art        php-xml.x86_64 0:5.3.6-5.el5.art   

Complete!
[root@u15559315 ~]# mv /etc/php.ini.rpmnew /etc/php.ini
mv: overwrite `/etc/php.ini'? y
[root@u15559315 ~]# mv /etc/php.ini.rpmnew /etc/php.ini
mv: cannot stat `/etc/php.ini.rpmnew': No such file or directory
[root@u15559315 ~]# mv /etc/httpd/conf.d/php.conf.rpmnew /etc/httpd/conf.d/php.conf
mv: cannot stat `/etc/httpd/conf.d/php.conf.rpmnew': No such file or directory
[root@u15559315 ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
[root@u15559315 ~]#
[root@u15559315 ~]#
[root@u15559315 ~]# php -v
PHP 5.3.6 (cli) (built: Aug  3 2011 12:13:41)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
[root@u15559315 ~]#

Note:

We use Hosting and VPS Hosting, from: www.star-host.org

We like and trust them.

Good prices, high security.