Print
Parent Category: Tutorials
Hits: 6484

 

In order to install i386 packages on x86_64 distro, you need to install  ia32-libs*:

 

 

# apt-get install ia32-libs
Reading package lists... Done  
Building dependency tree  
Reading state information... Done  
The following extra packages will be installed:  
lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1 libc6-i386
Suggested packages:  
libasound2-plugins  
The following NEW packages will be installed:  
ia32-libs lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1 libc6-i386
0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.  
Need to get 32.6MB of archives.  
After this operation, 141MB of additional disk space will be used.  
Do you want to continue [Y/n]? Y

 

For example, install Skype:

 

 

# dpkg -i --force-architecture skype-debian_2.0.0.72-1_i386.deb
dpkg - warning, overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 94936 files and directories currently installed.)
Preparing to replace skype 2.0.0.72-1 (using skype-debian_2.0.0.72-1_i386.deb) ...
Unpacking replacement skype ...
Setting up skype (2.0.0.72-1) ...

Note:

We use Hosting and VPS Hosting, from: www.star-host.org

We like and trust them.

Good prices, high security.